GSuite Incident Alert for Google Meet

Incident
July 06, 6:43am MST

GSuite Incident Alert for Google Meet

Status: closed
Start: June 29, 12:00am MST
End: July 06, 6:43am MST
Duration: 7 days 6 hours 43 minutes
Affected Components:
Cloud Services GSuite Google Meet
UPDATE

June 29, 12:00am MST

June 29, 12:00am MST

We're aware of a problem with Google Meet affecting a majority of users. We will provide an update by Jul 6, 2023, 12:30 PM UTC detailing when we expect to resolve the problem. Please note that this resolution time is an estimate and may change. The affected users are able to access Google Meet, but are seeing error messages, high latency, and/or other unexpected behavior.

UPDATE

July 06, 4:30am MST

July 06, 4:30am MST

We're aware of a problem with Google Meet affecting a majority of users. We will provide an update by Jul 6, 2023, 12:30 PM UTC detailing when we expect to resolve the problem. Please note that this resolution time is an estimate and may change. The affected users are able to access Google Meet, but are seeing error messages, high latency, and/or other unexpected behavior. Google Duo group calls have a degraded audio quality (metallic noise in the background) for all client types (iOS, Android, Web) 1:1 calls are not affected. Google Meet meetings are not impacted and can be used as a workaround.

UPDATE

July 06, 5:00am MST

July 06, 5:00am MST

We expect to resolve the problem affecting a majority of users of Google Meet at Jul 6, 2023, 1:30 PM UTC. Please note that this time frame is an estimate and may change. The affected users are able to access Google Meet, but are seeing error messages, high latency, and/or other unexpected behavior. Google Duo group calls have a degraded audio quality (metallic noise in the background) for all client types (iOS, Android, Web) 1:1 calls are not affected. Google Meet meetings are not impacted and can be used as a workaround.

UPDATE

July 06, 6:18am MST

July 06, 6:18am MST

We expect to resolve the problem affecting a majority of users of Google Meet at Jul 6, 2023, 2:30 PM UTC. Please note that this time frame is an estimate and may change. The affected users are able to access Google Meet, but are seeing error messages, high latency, and/or other unexpected behavior. Google Duo group calls have a degraded audio quality (metallic noise in the background) for all client types (iOS, Android, Web) 1:1 calls are not affected. Google Meet meetings are not impacted and can be used as a workaround.

RESOLVED

July 06, 6:43am MST

July 06, 6:43am MST

The problem with Google Meet has been resolved. We apologize for the inconvenience and thank you for your patience and continued support.