GSuite Incident Alert for Google Drive

Incident
August 17, 4:21pm MST

GSuite Incident Alert for Google Drive

Status: closed
Start: August 17, 12:56pm MST
End: August 17, 4:21pm MST
Duration: 3 hours 25 minutes
Affected Components:
Cloud Services GSuite Google Drive
UPDATE

August 17, 12:56pm MST

August 17, 12:56pm MST

We are experiencing an issue with multiple products of Google Workspace including Gmail, Google Docs, Google Drive Our engineering team continues to investigate the issue. We will provide an update by Thursday, 2023-08-17 15:00 US/Pacific with current details. We apologize to all who are affected by the disruption.

UPDATE

August 17, 2:41pm MST

August 17, 2:41pm MST

We are experiencing an issue with multiple products of Google Workspace including Gmail, Google Docs, Google Drive Our engineering team continues to investigate the issue. We will provide an update by Thursday, 2023-08-17 15:00 US/Pacific with current details. We apologize to all who are affected by the disruption.

UPDATE

August 17, 2:56pm MST

August 17, 2:56pm MST

We are experiencing an issue with multiple products of Google Workspace including Gmail, Google Docs, Google Drive Our engineering team is still investigating this issue and we will continue to provide regular updates on the status. We will provide an update by Thursday, 2023-08-17 16:30 US/Pacific with current details. We apologize to all who are affected by the disruption. Customer Symptoms: Customers may have instability in accessing the impacted products

RESOLVED

August 17, 4:21pm MST

August 17, 4:21pm MST

We are experiencing an issue with multiple products of Google Workspace including Gmail, The issue with Gmail, Google Docs, Google Drive has been resolved for all affected users as of Thursday, 2023-08-17 16:09 US/Pacific. We thank you for your patience while we worked on resolving the issue.